Page 1 of 1

Restart MPLS process

Posted: Sat Nov 16, 2019 2:18 am
by luranius
Hi fellow members,

Just checking if there is a command to reset MPLS process? This is a lab environment. For example, if I changed the label range using the command "mpls label range 100 199".

I tried "clear mpls ldp neighbor *" =, it didn't work. Restart the router works though but just wondering if there is a better way?

Thanks in advance :)

Re: Restart MPLS process

Posted: Sat Nov 16, 2019 6:17 am
by AnkitTiwari
disable mpls on the interface and reenable it .. it will work.

Re: Restart MPLS process

Posted: Sat Nov 16, 2019 4:00 pm
by luranius
Thanks AnkitTiwari for your reply.

Tried it .. no luck. Am I missing anything?

# no mpls ip
..
# mpls ip

Re: Restart MPLS process

Posted: Mon Nov 18, 2019 6:59 am
by luke_bromirski
Well, you can't in IOS, IOS-XE and NX-OS.

In IOS XR you can restart LDP, but the label range allocation is global value set at router boot.

There's enhancement however from 5.3.4, 6.1.2 and 7.0 that in IOS XR moves the label ranges dynamically - but I haven't found anything like that for our other OSes. The enhancement was introduced as part of fixing CSCva43602. You'll need anyway to execute 'clear mpls ldp forwarding' to start allocate labels from new range after change.